Skip navigation

Is anyone using Aegir in Ubuntu 12.04, appears to be a bug when installing.

Help

Is anyone using Aegir in Ubuntu 12.04, appears to be a bug when installing.

I've installed Aegir many times and its usually straight forward, today I tried installing Aegir under the new Ubuntu 12.04 and noticed it kept returning an error, I tried installing it 3 times on new Amazon EC2 instances just ot make sure I wasn't doing anything wrong. I then switched to Ubuntu 11.10 and it installed fine so I'm feeling this must be a 12.04 issue.

If anyone wants to replicate this on EC2 I'm using the following Amazon machine image: ami-a29943cb

Here's the end of the output where errors start appearing. I did use DPKG_DEBUG=developer

+ IFS=
read -r _db_internal_line
+ RET=true
+ return 0
+ db_stop
+ echo STOP
+ [ -d /var/aegir/.drush/provision ]
+ echo installing the Aegir frontend (Drupal with the hostmaster profile), please wait...
installing the Aegir frontend (Drupal with the hostmaster profile), please wait...
+ su aegir -c cd /var/aegir && drush hostmaster-install --yes --debug --backend ec2-23-20-22-146.compute-1.amazonaws.com | drush backend-parse
Bootstrap to phase 0. [0.05 sec, 2.8 MB]                             [bootstrap]
Drush bootstrap phase : _drush_bootstrap_drush() [0.05 sec, 3.02 MB] [bootstrap]
Project information for drupal retrieved.                            [ok]
drupal downloaded from                                               [ok]
http://ftp.drupal.org/files/projects/drupal-6.26.tar.gz.
hostmaster cloned from http://git.drupal.org/project/hostmaster.git. [ok]
Checked out tag 6.x-1.8.                                             [ok]
Found makefile: hostmaster.make                                      [ok]
Project information for admin_menu retrieved.                        [ok]
Project information for openidadmin retrieved.                       [ok]
Project information for install_profile_api retrieved.               [ok]
Project information for jquery_ui retrieved.                         [ok]
Project information for modalframe retrieved.                        [ok]
admin_menu downloaded from                                           [ok]
http://ftp.drupal.org/files/projects/admin_menu-6.x-1.8.tar.gz.
openidadmin downloaded from                                          [ok]
http://ftp.drupal.org/files/projects/openidadmin-6.x-1.2.tar.gz.
install_profile_api downloaded from                                  [ok]
http://ftp.drupal.org/files/projects/install_profile_api-6.x-2.1.tar.gz.
jquery_ui downloaded from                                            [ok]
http://ftp.drupal.org/files/projects/jquery_ui-6.x-1.3.tar.gz.
modalframe downloaded from                                           [ok]
http://ftp.drupal.org/files/projects/modalframe-6.x-1.6.tar.gz.
jquery_ui downloaded from                                            [ok]
http://jquery-ui.googlecode.com/files/jquery.ui-1.6.zip.
Dummy connection failed to fail:                                     [error]
Dummy connection failed to fail:                                     [error]
Created ec2232022146comp database                                    [success]
Dummy connection failed to fail:                                     [error]
Dummy connection failed to fail:                                     [error]
Could not find a Drupal settings.php file at                         [error]
./sites/community.aegirproject.org/settings.php.
Drush was not able to start (bootstrap) the Drupal database.         [error]
Hint: This error often occurs when Drush is trying to bootstrap a
site that has not been installed or does not have a configured
database.

Drush was attempting to connect to :
  Drupal version    : 6.26
  Default theme     : garland
  Administration theme: garland
  PHP configuration : /etc/php5/cli/php.ini
  Drush version     : 4.5
  Drush configuration: /var/aegir/hostmaster-6.x-1.8/drushrc.php
  Drush alias files : /var/aegir/.drush/hostmaster.alias.drushrc.php
/var/aegir/.drush/server_master.alias.drushrc.php
/var/aegir/.drush/platform_hostmaster.alias.drushrc.php
  Drupal root       : /var/aegir/hostmaster-6.x-1.8
  %paths            : Array

You can select another site with a working database setup by
specifying the URI to use with the --uri parameter on the command
line or $options['uri'] in your drushrc.php file.

Aegir 6.x-1.8 automated install script
==============================================================================
Some settings have not been provided and will now be prompted.
Don't worry: you will get to review those settings after the final install

This script will operate the following changes in your system:

1. Create server-level configuration directories
2. Download drush_make
3. Create the Hostmaster frontend platform
4. Install the frontend site
5. Setup the dispatcher (a user cron job)

We are making the following assumptions:
* you have read and are following the install instructions at:
    http://community.aegirproject.org/installing
* the FQDN of this machine is valid and resolves
* you are executing this script as your "aegir" user

The following settings will be used:
Aegir frontend URL: ec2-23-20-22-146.compute-1.amazonaws.com
Master server FQDN: localhost
Aegir root: /var/aegir
Aegir user: aegir
Web group: www-data
Web server: apache
Aegir DB host: localhost
Aegir DB user: root
Aegir DB password: <previously set>
Drush make version: 6.x-2.3
Aegir version: 6.x-1.8
Aegir platform path: /var/aegir/hostmaster-6.x-1.8
Aegir makefile: /usr/share/drush/commands/provision/aegir.make
Admin email: aegir@localhost

Do you really want to proceed with the install (y/n): y
dpkg: error processing aegir-hostmaster (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of aegir:
aegir depends on aegir-hostmaster (>= 1.8); however:
  Package aegir-hostmaster is not configured yet.
dpkg: error processing aegir (--configure):
dependency problems - leaving unconfigured
Setting up m4 (1.4.16-2ubuntu1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Setting up autoconf (2.68-1ubuntu2) ...
Setting up autotools-dev (20120210.1ubuntu1) ...
Setting up automake (1:1.11.3-1ubuntu2) ...
update-alternatives: using /usr/bin/automake-1.11 to provide /usr/bin/automake (automake) in auto mode.
Setting up binutils (2.22-6ubuntu1) ...
Setting up cpp-4.6 (4.6.3-1ubuntu5) ...
Setting up cpp (4:4.6.3-1ubuntu5) ...
Setting up gcc-4.6 (4.6.3-1ubuntu5) ...
Setting up gcc (4:4.6.3-1ubuntu5) ...
Setting up libc-dev-bin (2.15-0ubuntu10) ...
Setting up linux-libc-dev (3.2.0-24.37) ...
Setting up libc6-dev (2.15-0ubuntu10) ...
Setting up libhtml-template-perl (2.10-1) ...
Setting up libltdl-dev (2.4.2-1ubuntu1) ...
Setting up zlib1g-dev (1:1.2.3.4.dfsg-3ubuntu4) ...
Setting up libssl-dev (1.0.1-4ubuntu5) ...
Setting up libssl-doc (1.0.1-4ubuntu5) ...
Setting up libt1-5 (5.1.2-3.4ubuntu1) ...
Setting up libtool (2.4.2-1ubuntu1) ...
Setting up manpages-dev (3.35-0.1ubuntu1) ...
Setting up mysql-server (5.5.22-0ubuntu1) ...
Setting up php5 (5.3.10-1ubuntu3) ...
Setting up shtool (2.0.8-6) ...
Setting up php5-dev (5.3.10-1ubuntu3) ...
update-alternatives: using /usr/bin/php-config5 to provide /usr/bin/php-config (php-config) in auto mode.
update-alternatives: using /usr/bin/phpize5 to provide /usr/bin/phpize (phpize) in auto mode.
Setting up php5-gd (5.3.10-1ubuntu3) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
aegir-hostmaster
aegir
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ip-10-28-44-5:~#

Need help?

Discussion

The discussion area lets your team communicate by posting updates and discussing issues. It is a great place for sharing progress, discussing challenges, and exploring ideas.